[vmchecker-dev] logger naming

Lucian Adrian Grijincu lucian.grijincu at gmail.com
Tue Apr 28 00:58:43 EEST 2009


Hi,

I'd like to point out that we don't use names for loggers in s standard way:

./assignments.py:_logger = logging.getLogger('assignments')
./commander.py:_logger = logging.getLogger('vmchecker.commander')
./repo_walker.py:_logger = logging.getLogger('repo_walker')
./initialise_course.py:_logger =
logging.getLogger("vmchecker.initialise_course")
./submit.py:_logger = logging.getLogger('submit')
./queue_manager.py:_logger = logging.getLogger("vmchecker.queue_manager")
./update_db.py:_logger = logging.getLogger('update_db')

Alexandru wanted us to kill "vmchecker.", because it is implied.
Well, not exactly:

  DEBUG:paramiko.transport:Switch to new keys ...
  INFO:vmchecker.callback:Remote server host key is valid.
  DEBUG:paramiko.transport:userauth is OK

This is how output looks right now. I'd argue that having "vmchecker."
in front of names is better: we see exactly which message was created
by us and what was created by other components.
This will be more useful when we'll bring in python-libvirt and other
python modules.

-- 
 .
..: Lucian


More information about the vmchecker-dev mailing list